查看: 50407|回复: 289
打印 上一主题 下一主题

[指标技术] 寿光现货主图指标公式源码

  [复制链接]

该用户从未签到

36

主题

37

帖子

0

贡献值

初窥堂奥

Rank: 4

现货币
2565 枚
在线时间
23 小时
楼主
跳转到指定楼层
发表于 2011-12-8 20:22:30 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式
游客,如果您要查看本帖隐藏内容请回复

未命名12.jpg (86 KB, 下载次数: 67)

未命名12.jpg
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复

使用道具 举报

该用户从未签到

0

主题

18

帖子

0

贡献值

登堂入室

Rank: 2

现货币
4 枚
在线时间
12 小时
推荐
发表于 2015-3-31 15:25:12 | 只看该作者
买入价:=X;
DRAWTEXT(ISLASTBAR=1,买入价*0.999,'买入价'),COLORWHITE;
STICKLINE(买入价,买入价,买入价,10,1),COLORBB97BB;
DRAWNUMBER(ISLASTBAR,买入价,买入价,0),COLORWHITE;

止赢5%:=买入价*1.005;
DRAWTEXT(ISLASTBAR=1, 止赢5%*0.999,'止赢5%'),COLORFF00FF;
STICKLINE(止赢5%, 止赢5%, 止赢5%,10,1),COLOR000090;
DRAWNUMBER(ISLASTBAR,止赢5%,止赢5%,0),COLORFF00FF;

止赢10%:=买入价*1.01;
DRAWTEXT(ISLASTBAR=1, 止赢10%*0.999,'止赢10%'),COLORFF00FF;
STICKLINE(止赢10%, 止赢10%, 止赢10%,10,1),COLORB00060;
DRAWNUMBER(ISLASTBAR,止赢10%,止赢10%,0),COLORFF00FF;

止赢15%:=买入价*1.015;
DRAWTEXT(ISLASTBAR=1, 止赢15%*0.999,'止赢15%'),COLORFF00FF;
STICKLINE(止赢15%, 止赢15%, 止赢15%,10,1),COLOR008000;
DRAWNUMBER(ISLASTBAR,止赢15%,止赢15%,0),COLORFF00FF;

止赢20%:=买入价*1.02;
DRAWTEXT(ISLASTBAR=1, 止赢20%*0.999,'止赢20%'),COLORFF00FF;
STICKLINE(止赢20%, 止赢20%, 止赢20%,10,1),COLOR0000FF;
DRAWNUMBER(ISLASTBAR,止赢20%,止赢20%,0),COLORFF00FF;

止赢30%:=买入价*1.03;
DRAWTEXT(ISLASTBAR=1, 止赢30%*0.999,'止赢30%'),COLORFF00FF;
STICKLINE(止赢30%, 止赢30%, 止赢30%,10,1),COLOR0000FF;
DRAWNUMBER(ISLASTBAR,止赢30%,止赢30%,0),COLORFF00FF;


止损5%:=买入价-买入价*0.005;
DRAWTEXT(ISLASTBAR=1, 止损5%*0.999,'止损-5%'),COLORGREEN;
STICKLINE(止损5%, 止损5%, 止损5%,10,1),COLOR000090;
DRAWNUMBER(ISLASTBAR,止损5%,止损5%,0),COLORGREEN;

止损10%:=买入价-买入价*0.01;
DRAWTEXT(ISLASTBAR=1, 止损10%*0.999,'止损-10%'),COLORGREEN;
STICKLINE(止损10%, 止损10%, 止损10%,10,1),COLORB00060;
DRAWNUMBER(ISLASTBAR,止损10%,止损10%,0),COLORGREEN;

止损15%:=买入价-买入价*0.015;
DRAWTEXT(ISLASTBAR=1, 止损15%*0.999,'止损-15%'),COLORGREEN;
STICKLINE(止损15%, 止损15%, 止损15%,10,1),COLOR008000;
DRAWNUMBER(ISLASTBAR,止损15%,止损15%,0),COLORGREEN;

止损20%:=买入价-买入价*0.02;
DRAWTEXT(ISLASTBAR=1, 止损20%*0.999,'止损-20%'),COLORGREEN;
STICKLINE(止损20%, 止损20%, 止损20%,10,1),COLOR0000FF;
DRAWNUMBER(ISLASTBAR,止损20%,止损20%,0),COLORGREEN;


例子一。黄金分割?
买入价:= ref(c,1);{if(CROSS(DEA1,DIFF1),c,0);卖'}
DRAWTEXT(ISLASTBAR=1,买入价*0.999,'买入价'),COLORWHITE;
STICKLINE(ISLASTBAR and 买入价,买入价,买入价,10,1),COLORBB97BB;
DRAWNUMBER(ISLASTBAR,买入价,买入价,0),COLORWHITE;

止赢5%:=买入价*1.005;

STICKLINE(ISLASTBAR and 止赢5%, 止赢5%, 止赢5%,10,1),COLOR000090;
DRAWNUMBER(ISLASTBAR,止赢5%,止赢5%,0),COLORFF00FF;

止赢10%:=买入价*1.01;

STICKLINE(ISLASTBAR and 止赢10%, 止赢10%, 止赢10%,10,1),COLORB00060;
DRAWNUMBER(ISLASTBAR,止赢10%,止赢10%,0),COLORFF00FF;

止赢15%:=买入价*1.015;

STICKLINE(ISLASTBAR and 止赢15%, 止赢15%, 止赢15%,10,1),COLOR008000;
DRAWNUMBER(ISLASTBAR,止赢15%,止赢15%,0),COLORFF00FF;

止赢20%:=买入价*1.02;

STICKLINE(ISLASTBAR and 止赢20%, 止赢20%, 止赢20%,10,1),COLOR0000FF;
DRAWNUMBER(ISLASTBAR,止赢20%,止赢20%,0),COLORFF00FF;

止赢30%:=买入价*1.03;

STICKLINE(ISLASTBAR and 止赢30%, 止赢30%, 止赢30%,10,1),COLOR0000FF;
DRAWNUMBER(ISLASTBAR,止赢30%,止赢30%,0),COLORFF00FF;


止损5%:=买入价-买入价*0.005;

STICKLINE(ISLASTBAR and 止损5%, 止损5%, 止损5%,10,1),COLOR000090;
DRAWNUMBER(ISLASTBAR,止损5%,止损5%,0),COLORGREEN;

止损10%:=买入价-买入价*0.01;

STICKLINE(ISLASTBAR and 止损10%, 止损10%, 止损10%,10,1),COLORB00060;
DRAWNUMBER(ISLASTBAR,止损10%,止损10%,0),COLORGREEN;

止损15%:=买入价-买入价*0.015;

STICKLINE(ISLASTBAR and 止损15%, 止损15%, 止损15%,10,1),COLOR008000;
DRAWNUMBER(ISLASTBAR,止损15%,止损15%,0),COLORGREEN;

止损20%:=买入价-买入价*0.02;

STICKLINE(ISLASTBAR and 止损20%, 止损20%, 止损20%,10,1),COLOR0000FF;
DRAWNUMBER(ISLASTBAR,止损20%,止损20%,0),COLORGREEN;


{STICKLINE(买入价,止赢5%,止损5%,1,1),COLORgreen;}

例子二 在买卖点处加上?
买入价:=if(CROSS(ma(c,20),ma(c,10)),c,0);{卖出}
DRAWTEXT(ISLASTBAR=1,买入价*0.999,'买入价'),COLORWHITE;
STICKLINE(ISLASTBAR and 买入价,买入价,买入价,10,1),COLORBB97BB;
DRAWNUMBER(ISLASTBAR,买入价,买入价,0),COLORWHITE;

止赢5%:=买入价*1.005;

STICKLINE(ISLASTBAR and 止赢5%, 止赢5%, 止赢5%,20,1),COLOR000090;
DRAWNUMBER(ISLASTBAR,止赢5%,止赢5%,0),COLORFF00FF;

止损5%:=买入价-买入价*0.005;

STICKLINE(ISLASTBAR and 止损5%, 止损5%, 止损5%,10,1),COLOR000090;
DRAWNUMBER(ISLASTBAR,止损5%,止损5%,0),COLORGREEN;
STICKLINE(买入价,止赢5%,止损5%,1,1),COLORgreen;
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

5

主题

65

帖子

0

贡献值

登堂入室

Rank: 2

现货币
57 枚
在线时间
20 小时
推荐
发表于 2017-8-13 12:23:23 | 只看该作者
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
成交:=VOL;
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
买卖差:=(买盘 + 卖盘);
STICKLINE((VOL > 0),VOL,0,4,1),colorFFFFFF;
STICKLINE((买卖差 > 0),0,买卖差,4,0),color0000FF;
STICKLINE((买卖差 < 0),0,买卖差,2,0),LINETHICK3,color33FF33;
量比1:=(VOL / MA(VOL,5));
VAR10:=买盘;
VAR20:=卖盘;
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR30:=MA(VOL,JY2);
动神:=买盘;
鬼力:=VAR20;
神比:=(动神 / VAR30);
鬼比:=(鬼力 / VAR30);
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));

VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,动神) + 动神) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,动神) + 动神) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,动神) + 动神) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,鬼力) + 鬼力) / 2);
三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
三日下攻:=MA(VAR50,JY2);
多头:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,4,1),color0000FF;
空头:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,4,1),color00FF00;
STICKLINE((鬼力 > 0),鬼力,0,4,0),colorFF3399;
加仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,4,0),color00FFFF;
减仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),0,VAR6,4,0),colorFF0000;
洗盘:STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,4,0),colorFFFFFF;
高卖:STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,4,0),colorFF00FF;
相对地量:=STICKLINE(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),0,VOL,3,0);
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

3

主题

385

帖子

0

贡献值

初窥堂奥

Rank: 4

现货币
79 枚
在线时间
127 小时
推荐
发表于 2015-4-25 16:12:21 | 只看该作者
Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
快线:3*Q3-2*Q4,COLORWHITE,LINETHICK2;
趋势线:EMA(Q3, 3),COLORRED,LINETHICK1;
DRAWTEXT(CROSS(趋势线, 快线) AND REF(快线,1)>80, REF(快线,3), '顶'),COLORRED,LINETHICK5;
逢低买: DRAWTEXT(REF(CROSS(趋势线,快线),82) AND 趋势线>1.3*快线,快线,'逢低买'),LINETHICK1;
买: DRAWTEXT(REF(CROSS(快线,趋势线),1) AND 快线>1.3*趋势线,趋势线,'买'),COLORRED,LINETHICK1;
{VAR3:=(3,15,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);}
金叉:= CROSS(快线,趋势线);
DRAWTEXT(金叉,趋势线,'★'),COLORRED;
技术交流QQ2569724103
回复 支持 反对

使用道具 举报

该用户从未签到

0

主题

117

帖子

0

贡献值

圆转纯熟

Rank: 3Rank: 3

现货币
0 枚
在线时间
50 小时
5#
发表于 2011-12-8 20:56:12 | 只看该作者
正在寻找 谢谢提供
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

4

主题

579

帖子

0

贡献值

自成一派

Rank: 8Rank: 8

现货币
9 枚
在线时间
775 小时
6#
发表于 2011-12-8 21:44:47 | 只看该作者
[s:536] [s:535] [s:538] [s:537] [s:541] [s:546] [s:545]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

12

主题

292

帖子

0

贡献值

炉火纯青

Rank: 7Rank: 7Rank: 7

现货币
110 枚
在线时间
386 小时
7#
发表于 2011-12-8 22:55:47 | 只看该作者
[s:533]  [s:533]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

2

主题

47

帖子

0

贡献值

略有小成

Rank: 5Rank: 5

现货币
19 枚
在线时间
277 小时
8#
发表于 2011-12-8 23:01:06 | 只看该作者
[s:533] [s:533] [s:533]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

345

主题

1068

帖子

0

贡献值

登峰造极

Rank: 10Rank: 10Rank: 10

现货币
1533 枚
在线时间
3357 小时
9#
发表于 2011-12-9 08:55:16 | 只看该作者
[s:537]  [s:537]
凤凰涅磐 浴火重生 王者归来 必将所向披靡 !!!
回复 支持 反对

使用道具 举报

该用户从未签到

0

主题

408

帖子

0

贡献值

炉火纯青

Rank: 7Rank: 7Rank: 7

现货币
82 枚
在线时间
676 小时
10#
发表于 2011-12-9 23:07:59 | 只看该作者
0000000000
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

0

主题

110

帖子

0

贡献值

初窥堂奥

Rank: 4

现货币
4 枚
在线时间
144 小时
11#
发表于 2011-12-10 00:13:05 | 只看该作者
[s:542]  [s:538]  [s:539]  [s:540]  [s:544]  [s:548]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

1

主题

39

帖子

0

贡献值

登堂入室

Rank: 2

现货币
3 枚
在线时间
8 小时
12#
发表于 2011-12-10 21:19:20 | 只看该作者
很不错,学习了
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

7

主题

173

帖子

0

贡献值

炉火纯青

Rank: 7Rank: 7Rank: 7

现货币
811 枚
在线时间
523 小时
13#
发表于 2011-12-11 10:48:11 | 只看该作者
ggggggggggggggggggggggggggggggggggggggggggggggggggggg
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

发表回复

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表